Zurück   Flashforum > Alternative Technologien > HTML und CSS

Antwort
 
LinkBack Themen-Optionen Ansicht
Alt 07-10-2010, 14:58   #1 (permalink)
Neuer User
 
Registriert seit: Sep 2009
Beiträge: 10
SWF Datei wird unter Dreamweaver nicht angezeigt

Hallo Leute ich habe ein kleine Problem.

Ich habe mir ein Flash-Karussell unter CS4 erstellt und wollte dieses per Dreamweaver auf die Internetseite stellen.
Leider sehe ich nur ein weißes bild ohne die Flash-Datei.
Ich verwende den swf-file und binde über mehrere Möglichkeiten ein.
Die Datei ist auf den Server geladen und funktioniert unter Flash und Firefox.

Schaut euch doch bitte mal mein Karussell an und helft mir, wie ich dieses Problem lösen kann.

Das Karussell besteht aus 3 Dateien. Eine XML und eine JS Datei, sowie die Fla und die Swf.

http://www.lineasogno.de/actsea/flas...ssell-v2.4.swf

Vielen Dank im Voraus
jamba1103 ist offline   Mit Zitat antworten
Alt 07-10-2010, 15:15   #2 (permalink)
experience++;
 
Benutzerbild von salazar
 
Registriert seit: Jul 2002
Ort: Düsseldorf
Beiträge: 12.210
hey,
hab deinen beitrag mal verschoben. hier geht es ja nicht um flash selbst, sondern um die korrekte einbindung in eine html seite.

dazu würde ich dann auch mal die html seite posten, damit sich das unser einer mal anschauen kann.

cheers,
sal
__________________
Bitte keine Flashfragen an mich schicken. Dafür ist ja das Forum da! Das betrifft auch Profilnachrichten.
salazar ist offline   Mit Zitat antworten
Alt 07-10-2010, 15:30   #3 (permalink)
Neuer User
 
Registriert seit: Sep 2009
Beiträge: 10
nachgereichte HTML

Hallo zusammen.

Hier ist die HTML-Seite.

Hoffe Ihr könnt hier besser mein Problem erkennen.

Vielen Dank.

http://www.lineasogno.de/actsea/actsea_index.html
jamba1103 ist offline   Mit Zitat antworten
Alt 07-10-2010, 17:54   #4 (permalink)
experience++;
 
Benutzerbild von salazar
 
Registriert seit: Jul 2002
Ort: Düsseldorf
Beiträge: 12.210
hi,
grad erst wieder zum schauen gekommen...
ich seh da eine swf. haste es jetzt schon selsbt korrigiert??

cheers,
sal
__________________
Bitte keine Flashfragen an mich schicken. Dafür ist ja das Forum da! Das betrifft auch Profilnachrichten.
salazar ist offline   Mit Zitat antworten
Alt 27-01-2011, 02:32   #5 (permalink)
Neuer User
 
Registriert seit: Oct 2010
Beiträge: 11
Hallo Freunde

Ich habe das gleiche Problem wie der Threadstarter.

Nachdem ich die letzten 6 Stunden mein Flash Karussel zusammengebaut habe verzweifle ich gerade, weil keine html-Seite meine SWF anzeigen will.

Weder im Explorer, feiafochs oder opera.
Ich versteh das einfach nicht. Ist ja nicht so, dass ich zum ersten mal eine Flashfile einbinden will.

Nunja, ich stell euch die swf-file und fla mal zur Verfügung, vielleicht kann ja jemand mal versuchen, diese einzubinden.

Ich vermute das Problem liegt darin, dass die swf-file nur mit der entsprechenden xml-datei und den entsprechenden icons arbeitet.

Allerdings sind diese bei mir lokal alle auf einem Ordner. Weiß jemand wie ich diese XML-Datei und die icons in die HTML laden soll, damit die SWF funktioniert?

Am besten schaut ihr euch auch die Fla dazu an. Obwohl diese ohne xml und icons wohl auch nicht funktioniert.

Btw. xml datei lässt sich nicht hochladen, deswegen hier in txt. format, bei verwendung einfach in xml umbennen. Fügt dann noch ein paar entsprechende icons hinzu, und das karussel sollte drehen.

Ich danke jetzt schon für die HIlfe.

Rock'n'Roll!
George
Angehängte Dateien
Dateityp: swf carousel3.swf (18,7 KB, 5x aufgerufen)
Dateityp: fla carousel3.fla (82,0 KB, 2x aufgerufen)
Dateityp: txt icons.txt (2,7 KB, 3x aufgerufen)
soigroeg ist offline   Mit Zitat antworten
Alt 27-01-2011, 07:17   #6 (permalink)
Inventar
 
Benutzerbild von Nightflyer
 
Registriert seit: Jul 2002
Beiträge: 7.057
Gib noch die HTML dazu
__________________
(\__/)
(='.'=)
(")_(")
Nightflyer ist offline   Mit Zitat antworten
Alt 27-01-2011, 14:07   #7 (permalink)
Neuer User
 
Registriert seit: Oct 2010
Beiträge: 11
Hier die HTML

Kann die HTML leider nicht hochladen daher hier der Code:

Code:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>Unbenanntes Dokument</title>
<style type="text/css">
<!--
body {
	background-color: #000000;
}
-->
</style>
<script src="Scripts/swfobject_modified.js" type="text/javascript"></script>
</head>

<body>
<object id="FlashID" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="1000" height="300">
  <param name="movie" value="images/navigation - flash/Flashkarussel/carousel3.swf" />
  <param name="quality" value="high" />

  <param name="wmode" value="opaque" />
  <param name="swfversion" value="8.0.35.0" />
  <!-- Dieses param-Tag fordert Benutzer von Flash Player 6.0 r65 und höher auf, die aktuelle Version von Flash Player herunterzuladen. Wenn Sie nicht wünschen, dass die Benutzer diese Aufforderung sehen, löschen Sie dieses Tag. -->
  <param name="expressinstall" value="Scripts/expressInstall.swf" />
  <!-- Das nächste Objekt-Tag ist für Nicht-IE-Browser vorgesehen. Blenden Sie es daher mit IECC in IE aus. -->
  <!--[if !IE]>-->
  <object type="application/x-shockwave-flash" data="images/navigation - flash/Flashkarussel/carousel3.swf" width="1000" height="300">
    <!--<![endif]-->
    <param name="quality" value="high" />

    <param name="wmode" value="opaque" />
    <param name="swfversion" value="8.0.35.0" />
    <param name="expressinstall" value="Scripts/expressInstall.swf" />
    <!-- Im Browser wird für Benutzer von Flash Player 6.0 und älteren Versionen der folgende alternative Inhalt angezeigt. -->
    <div>
      <h4>Für den Inhalt dieser Seite ist eine neuere Version von Adobe Flash Player erforderlich.</h4>
      <p><a href="http://www.adobe.com/go/getflashplayer"><img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Adobe Flash Player herunterladen" width="112" height="33" /></a></p>
    </div>

    <!--[if !IE]>-->
  </object>
  <!--<![endif]-->
</object>
<script type="text/javascript">
<!--
swfobject.registerObject("FlashID");
//-->
</script>
</body>
</html>
Wie gesagt, ich hab in der HTML nichts anderes bis auf die SWF-File.

Interessanterweise funktioniert die SWF-File auch nicht lokal auf meinem Rechner, wenn ich sie aus dem Ordner mit der XML-Datei und den icons entferne.

Die Frage ist daher:
Wie sorge ich dafür, dass die XML-Datei und die icons gleich mit in die HTML geladen werden?
soigroeg ist offline   Mit Zitat antworten
Alt 27-01-2011, 14:24   #8 (permalink)
Neuer User
 
Registriert seit: Oct 2010
Beiträge: 11
Lösung:

Auch wenn es eine etwas unschöne Lösung ist.

Das Problem löst sich, wenn man die .xml-Datei in den gleichen Ordner steckt, in der die SWF-File eingebettet ist. Im Klartext muss HTML-File UND .XML-File im gleichen Ordner sein.

Es kommt einfach auf die exakte Location der .XML und der Icons an.

Trotzdem danke für die Antworten!
soigroeg ist offline   Mit Zitat antworten
Antwort

Lesezeichen

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks sind an
Pingbacks sind an
Refbacks sind an


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Maushand unter Mac wird nicht mehr angezeigt! rady Flash CS4 Professional 5 30-01-2010 18:48
dynamisches textfeld wird unter bestimmten einstellungen nicht angezeigt Ciko Flash CS3 Professional 2 21-08-2007 18:05
text unter einer maske wird nicht angezeigt jolly27 Flash Einsteiger 2 05-06-2006 13:48
Flash wird unter Netscape nicht angezeigt ScreamingLord Flash 4 und Flash 5 2 10-01-2003 10:33


Alle Zeitangaben in WEZ +1. Es ist jetzt 14:26 Uhr.

Domains, Webhosting & Vserver von Host Europe
Unterstützt das Flashforum!
Adobe User Group


Copyright ©1999 – 2014 Marc Thiele