Zurück   Flashforum > Alternative Technologien > HTML und CSS

Antwort
 
LinkBack Themen-Optionen Ansicht
Alt 23-11-2010, 15:29   #1 (permalink)
Neuer User
 
Registriert seit: Sep 2010
Beiträge: 7
lokale html funktioniert nicht auf anderen Rechnern - swffit schuld?

Hallo zusammen!

Ich habe eine swf mittels swfobject in eine html-Seite gebaut.
Zusätzlich nutze ich swffit um die Scrollbalken der Browser optimal zu nutzen.

Wenn ich die lokale html-Seite bei mir auf dem Rechner teste, sprich in verschiedenen Browsern öffne, dann funktioniert das auch wunderbar.

Auf anderen Rechnern hingegen, funktioniert das swf bzw. die html nicht mehr
korrekt. Die swf läßt sich nicht mehr steuern,movieclips spielen einfach ab(sie enthält buttons, animationen etc.). swffit funktioniert nicht mehr.

An den Dateien wurde nichts geändert. Es wurden die gleichen Browser getestet (Firefox, IE, Opera) und JavaScript ist auch immer aktiviert.

JavaScript funktioniert ja auch prinzipiell, sonst würde ja erst gar nicht die swf angezeigt, da sie ja mittel swfobject eingebettet ist,oder?

Ich vermute, dass es an swffit liegt. Wenn ich swffit aus dem html-Dokument und der swf weglasse, dann funktioniert soweit alles wieder.

Hier der Aufbau der html-Seite:
HTML-Code:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
	<head>
		<title>Mein Titel</title>
		<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
		<script type="text/javascript" src="swfobject.js"></script>
		<script type="text/javascript" src="swffit.js"></script>
		<script type="text/javascript">
			var flashvars = {};
			var params = {};
			var attributes = {};
			params.allowfullscreen = "true";
			params.bgcolor = "222222";			
			attributes.align = "left";
			swfobject.embedSWF("meineSWF.swf", "AlternativeContent", "100%", "100%", "9.0.0", "expressInstall.swf", flashvars, params, attributes);
		</script>
	
    <link rel="SHORTCUT ICON" href="bilder/favicon.ico" type="image/x-icon">
    <link rel="icon" href="bilder/favicon.ico" type="image/x-icon">
    
     <style type="text/css" media="screen">
		html, body { height:100%; background-color: #222222;}
		body { margin:0; padding:0; overflow:auto; }
		#flashContent { width:100%; height:100%; }
     </style>
    
    </head>
	    
    <body>
		<div id="AlternativeContent">
			<a href="http://www.adobe.com/go/getflashplayer">
				<img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Please get Adobe Flash player and allow javascript to see the content of this site." />
			</a>
		</div>
	</body>

</html>
 
    
und hier ein Auszug aus meiner .fla swffit betreffend:
PHP-Code:
//Import the SWFFit class
import swffitClass.daten.SWFFit;

//Import the SWFFitEvent class (only needed with you want to use SWFFit custom events)
import swffitClass.daten.SWFFitEvent;

//Initial swffit configuration
SWFFit.fit('AlternativeContent'1440900); 
Hat jemand eine Idee oder auch dieses Problem?

Vielen Dank und Gruß
elgardo
elgardo ist offline   Mit Zitat antworten
Alt 26-11-2010, 07:53   #2 (permalink)
Neuer User
 
Registriert seit: Sep 2010
Beiträge: 7
Niemand eine Idee?

Bin mir sicher, dass es an swffit liegt.
Fehler laut IE: 'SWFFIT ist undefiniert'

Nur was da jetzt konkret undefiniert ist - keine Ahnung...
Ich verstehe auch nicht, warum es dann auf meinem Rechner trotz der
Fehlermeldung funktioniert und auf anderen wiederum nicht.

Gruß
elgardo
elgardo ist offline   Mit Zitat antworten
Antwort

Lesezeichen

Stichworte
flash und html, lokale html, swffit, swfobject

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks sind an
Pingbacks sind an
Refbacks sind an


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Tween Klasse funktioniert nicht bei allen Rechnern gleich Allhaas Flash 8 0 21-02-2008 22:58
veröffentlichtes swf läuft auf manchen Rechnern/Browsern, auf anderen nicht! Steril707 ActionScript 3 3 01-02-2008 10:24
Upload-Skript funktioniert nicht, register-globals schuld ... Laeufer007 PHP und MySQL 14 23-03-2005 14:17
Funktioniert das auf MAC-rechnern nicht? milhouse1978 Autorensysteme 1 03-09-2003 13:05
loading funktioniert auf div. rechnern nicht santos Flash 4 und Flash 5 2 04-02-2003 11:39


Alle Zeitangaben in WEZ +1. Es ist jetzt 00:36 Uhr.

Domains, Webhosting & Vserver von Host Europe
Unterstützt das Flashforum!
Adobe User Group


Copyright ©1999 – 2014 Marc Thiele