Zurück   Flashforum > Flex und AIR > Flex programmieren

Antwort
 
LinkBack Themen-Optionen Ansicht
Alt 14-07-2011, 10:43   #1 (permalink)
Neuer User
 
Registriert seit: Aug 2009
Ort: Berlin
Beiträge: 271
Problem LinienChart mit eigenen Farben, aber Legend bleibt schwarz!

Bei der ersten Linie habe ich zum Test die Standard-Farbe gelassen, diese wird dann auch bei der Legende benutzt.
Nur die Linen mit eigener Farbe sind in der legend schwarz!

Code:
	<fx:Declarations>
		<!-- Platzieren Sie nichtvisuelle Elemente (z.*B. Dienste, Wertobjekte) hier -->
		<mx:SolidColorStroke id="s1" color="#FF0000" weight="5"/>
		<mx:SolidColorStroke id="s2" color="#FFFF00" weight="5"/>
		<mx:SolidColorStroke id="s3" color="#00FF00" weight="5"/>
	</fx:Declarations>

...

	<mx:LineChart id="ID_CHART" left="10" bottom="10" top="147" width="906" fontSize="20">
		<mx:backgroundElements>
			<mx:GridLines horizontalChangeCount="1" verticalChangeCount="1">
				<mx:verticalFill>
					<mx:SolidColor color="0x99033" alpha=".66"/>
				</mx:verticalFill>
				<mx:verticalStroke>
					<mx:SolidColorStroke weight="3"/>
				</mx:verticalStroke>
			</mx:GridLines>
		</mx:backgroundElements>
		
		<mx:horizontalAxis>
			<mx:CategoryAxis categoryField="jahr" title="Jahre"/>
		</mx:horizontalAxis>
		<mx:verticalAxis><mx:LinearAxis	title="... in Euro" id="yAxis"/></mx:verticalAxis>
		<mx:verticalAxisRenderers>
			<mx:AxisRenderer axis="{yAxis}" verticalAxisTitleAlignment="vertical" />
		</mx:verticalAxisRenderers>
		<mx:series>
			<mx:LineSeries yField="std" form="curve" displayName="Ist-Zustand" 	/>
			<mx:LineSeries yField="v1" 	form="curve" displayName="V1" 			lineStroke="{s2}"/>
			<mx:LineSeries yField="v2" 	form="curve" displayName="V2" 			lineStroke="{s3}"/>
		</mx:series>
	</mx:LineChart>
	<mx:Legend dataProvider="{ID_CHART}" top="147" height="151" x="924" width="86"/>
Angehängte Grafiken
Dateityp: jpg chart.jpg (4,0 KB, 6x aufgerufen)
__________________
MfG toosten

IDE: Adobe® Flex® Builder™ 3, Adobe® Flash® Builder™ 4
toosten ist offline   Mit Zitat antworten
Alt 14-07-2011, 10:49   #2 (permalink)
Neuer User
 
Registriert seit: Oct 2008
Beiträge: 148
hi,
liegts vielleicht da dran?

Code:
<mx:SolidColorStroke id="s1" color="#FF0000" weight="5"/>

<mx:SolidColorStroke id="s1" color="0xFF0000" weight="5"/>
sytch ist offline   Mit Zitat antworten
Alt 14-07-2011, 10:56   #3 (permalink)
Neuer User
 
Registriert seit: Aug 2009
Ort: Berlin
Beiträge: 271
Danke, aber leider immer noch schwarz.
__________________
MfG toosten

IDE: Adobe® Flex® Builder™ 3, Adobe® Flash® Builder™ 4
toosten ist offline   Mit Zitat antworten
Alt 14-07-2011, 11:05   #4 (permalink)
Neuer User
 
Registriert seit: Aug 2009
Ort: Berlin
Beiträge: 271
So, jetzt gehts - aber nur mit Warnung.

Beschreibung Ressource Pfad Position Typ
3608: „Stroke“ wird seit 4.0 nicht mehr verwendet. Verwenden Sie „SolidColorStroke“.

Code:
		<mx:Stroke id="s1" color="0xFF0000" weight="5"/>
		<mx:Stroke id="s2" color="0xFFFF00" weight="5"/>
		<mx:Stroke id="s3" color="0x00FF00" weight="5"/>
Falls jemand eine Lösung ohne Verwarnung kennt, würde ich mich über eine Info freuen.
__________________
MfG toosten

IDE: Adobe® Flex® Builder™ 3, Adobe® Flash® Builder™ 4
toosten ist offline   Mit Zitat antworten
Antwort

Lesezeichen

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks sind an
Pingbacks sind an
Refbacks sind an


Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
flv stream bleibt schwarz sumsgumsel Flash MX 2004 3 04-05-2006 15:16
cam bei flash bleibt immer schwarz... _level0 Am Rande 1 09-03-2006 00:20
Hilfe Bild bleibt schwarz Silent Flash MX 6 05-01-2006 19:56
Starfield bleibt schwarz Daniel73 ActionScript 1 9 15-02-2005 22:58
flashfilm bleibt schwarz dallahh HTML und CSS 4 25-04-2004 14:41


Alle Zeitangaben in WEZ +1. Es ist jetzt 05:34 Uhr.

Domains, Webhosting & Vserver von Host Europe
Unterstützt das Flashforum!
Adobe User Group


Copyright ©1999 – 2014 Marc Thiele